Back to overview
Degraded
SMTP Connections
May 23 at 11:20am BST
Affected services
Shared Mail Servers
Created
May 23 at 11:20am BST
We are aware of reports of some intermittent SMTP connectivity, the team are looking into this as a priority.
Update - We are aware of the impact on email deliverability for inbound email.
Affected services
Shared Mail Servers